The DNO power outage resolution time has been extended several times and is now estimated to be resolved by 16:00 on 13/03/2026.
We will continue to closely monitor the cabinet throughout this period and will do everything possible to keep it operational until grid power is restored.
However, due to the prolonged loss of DNO supply, there is a possibility that the cabinet may lose power despite our efforts. Should this occur, services connected to the Lasham cabinet may experience interruption or a complete loss of service.
We will provide further updates as the situation progresses.
Posted Mar 13, 2026 - 02:08 GMT
Identified
We are currently aware of an ongoing DNO power issue affecting the LASHAM area and surrounding locations.
Due to the scale of this outage, an engineer has been dispatched to recharge the cabinet battery to help maintain service stability.
Please be advised that if DNO grid power is not restored by mid-morning tomorrow, services connected to the Lasham cabinet may begin to experience degradation or interruption.
We will continue to monitor the situation closely and provide updates as more information becomes available.
Posted Mar 12, 2026 - 22:05 GMT
This incident affected: Broadband Services (Fibre to the Premise Services) and Business Ethernet Services.