00264798: EMERGENCY PLANNED MAINTENANCE AFFECTING VOICE/DATA SERVICES - MULTIPLE LOCATIONS

Incident Report for Wessex Internet

Resolved

This incident has been resolved.
Posted May 02, 2025 - 06:50 BST

Identified

The emergency maintenance is taking longer than expected. Our team is working diligently to complete the work as soon as possible. We appreciate your patience and understanding
Posted May 02, 2025 - 06:15 BST
This incident affected: Broadband Services (Fibre to the Premise Services).