Melbury Bub, Urless, West Chelborough, East Chelborough and Halstock - Power outage
Incident Report for Wessex Internet
Resolved
Power has been restored to the affected area. We apologise for any inconveniences caused
Posted Jul 24, 2021 - 20:21 BST
Investigating
We have had an unexpected power outage and affecting customers in the Melbury Bub, Urless, West Chelborough, East Chelborough and Halstock area. We are investigating the issue. Apologies for any inconvenience.
Posted Jul 24, 2021 - 12:04 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).