Unexpected Wessex Internet call centre outage
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 07:52 GMT
Monitoring
Our call system has been restored, and we are monitoring to ensure stability.
Posted Mar 21, 2024 - 16:21 GMT
Investigating
We are currently experiencing an unexpected outage of calls to and from our call centre. We are actively investigating to get this resolved as soon as possible.
Posted Mar 21, 2024 - 16:08 GMT
This incident affected: Contacting us/ Tools/ Portals (Telephone System).