Emergency Maintenance
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 10:55 GMT
Update
We are continuing to investigate this issue.
Posted Mar 14, 2024 - 10:54 GMT
Investigating
We are completing essential emergency network maintenance between 13/03/2024 at 18:00 and 13/03/2024 at 19.00

Customers in the Blandford area may experience downtime during the maintenance activity window.

Apologies in advance for any inconvenience this may cause.
Posted Mar 13, 2024 - 11:12 GMT
This incident affected: Broadband Services (Fibre to the Premise Services) and Business Ethernet Services.