We are currently experiencing issues with our phone lines
Incident Report for Wessex Internet
Resolved
This incident has now been resolved. Sorry for any inconvenience caused.
Posted Feb 06, 2019 - 17:00 GMT
Investigating
We are investigating the issue. Please email info@wessexinternet.com any queries. Apologies for any inconvenience.
Posted Feb 06, 2019 - 10:58 GMT