Outage - Prescombe/Bowerchalke
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted May 21, 2020 - 12:58 BST
Investigating
We are aware that there is an issue currently affecting customers in Prescombe/Bowerchalke. We are investigating this at the moment, and further updates will be posted here.

We apologize for any inconvenience caused.
Posted May 21, 2020 - 12:53 BST
This incident affected: Broadband Services (Fixed-wireless Services).