Unexpected outage - Delcombe, Hilton and surrounding areas

Incident Report for Wessex Internet

Resolved

This incident has been resolved.
Posted May 21, 2023 - 06:12 BST

Identified

The issue has been identified and a fix is being implemented.
Posted May 20, 2023 - 20:23 BST

Investigating

We have had an unexpected power outage, that is affecting customers in the Delcombe and Hilton area.
We are investigating the issue and apologise for any inconvenience.
Posted May 20, 2023 - 19:01 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).