Poor Performance - Urless, West Chelborough, East Chelborough and Halstock
Incident Report for Wessex Internet
Resolved
After monitoring the connection in the area there has been no further drop outs. We apologise for any inconveniences caused due to the degraded performance and if you are still experiencing any lasting issues please get in contact
Posted Jul 23, 2021 - 16:31 BST
Monitoring
Engineers have gone to site and implemented a fix and we will monitor this closely for the rest of the day
Posted Jul 23, 2021 - 13:56 BST
Investigating
We are aware that there is an issue currently affecting wireless customers in Urless, West Chelborough, East Chelborough and Halstock. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Jul 23, 2021 - 10:19 BST
This incident affected: Broadband Services (Fixed-wireless Services).