Schedule maintenance - Bowers Barn
Scheduled for May 9, 22:00 BST  -  May 10, 06:00 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 16, 2024 - 15:32 BST
Scheduled
We are completing network maintenance on the 09/05/2024 from 22.00 and 06:00 on the 10/05/2024

Customers in Iwerne Minster and surrounding areas will experience downtime during the maintenance activity window.

The outage is necessary to allow our engineers to carry out the required works to the equipment safely. We apologies in advance for any inconvenience this may cause.
Posted Apr 16, 2024 - 15:30 BST
This scheduled maintenance affects: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services) and Business Ethernet Services.