Pentridge area - Power outage
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted May 29, 2020 - 13:41 BST
Investigating
We have had an unexpected SSE power outage and affecting customers in the Pentridge and surrounding areas. Apologies for any inconvenience.
Posted May 29, 2020 - 11:12 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).