Outage - Holwell Area
Incident Report for Wessex Internet
Resolved
This outage has now been resolved we apologise for any interruptions caused
Posted May 04, 2021 - 11:32 BST
Investigating
We are aware that there is an issue currently affecting customers in Holwell area. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted May 04, 2021 - 11:19 BST
This incident affected: Broadband Services (Fixed-wireless Services).