Emergency Maintenance - Shillingstone Area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Jun 21, 2024 - 14:53 BST
Investigating
We are running some emergency maintenance on our cabinets in the Shillingstone area, due to this customers can expect potential downtime of up to an hour.
Posted Jun 21, 2024 - 08:43 BST
This incident affected: Broadband Services (Fibre to the Premise Services).