Outage - Blandford St Mary
Incident Report for Wessex Internet
Resolved
This fibre break has now been resolved. Apologise to all customers affected by this outage
Posted Oct 08, 2021 - 16:46 BST
Identified
We have engineers heading out to site and have identified the fault as a fibre break
Posted Oct 08, 2021 - 13:38 BST
Investigating
We are aware that there is an issue currently affecting customers in Blandford St Mary. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Oct 08, 2021 - 11:42 BST
This incident affected: Broadband Services (Fibre to the Premise Services).