Outage - Farnham Area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 09:55 GMT
Investigating
We are aware that there is an issue currently affecting customers in the Farnham. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Mar 24, 2020 - 17:02 GMT
This incident affected: Broadband Services (Fixed-wireless Services).