Outage - Blandford St Mary
Incident Report for Wessex Internet
Resolved
This outage is now resolved - Thank you for your understanding
Posted Feb 26, 2021 - 18:14 GMT
Investigating
We are aware that there is an issue currently affecting customers in Blandford St Mary area. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Feb 26, 2021 - 17:10 GMT
This incident affected: Broadband Services (Fibre to the Premise Services).