Direct Debit Notification Error
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 11:47 GMT
Investigating
Unfortunately, due to an error with our direct debit process, customers may have received an email this morning stating that they would be billed an incorrect amount.

If you have a Direct Debit with us, please be assured that this payment will not be taken.

We have paused all Direct Debits to ensure the issue has been fully resolved and will update customers early next week when we are ready to request the correct payment for this month's invoice.

We’re very sorry for this mistake and the concern caused.
Posted Sep 13, 2024 - 10:45 BST
This incident affected: Contacting us/ Tools/ Portals (Direct Debit Payments).