Bulbarrow and Warden Hill Outage
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Dec 01, 2018 - 15:44 GMT
Investigating
We are currently experiencing an outage in this area. We are currently working to resolve this issue.
Posted Nov 30, 2018 - 15:58 GMT
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).