Outage - Cucklington
Incident Report for Wessex Internet
Resolved
Our engineer has been out on site and resolved the issue. We apologise for any inconvenience caused
Posted Jan 07, 2022 - 12:47 GMT
Investigating
We are aware that there is an issue currently affecting customers in Cucklington area. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Jan 07, 2022 - 11:25 GMT
This incident affected: Broadband Services (Fibre to the Premise Services).