Unexpected Issues - Phone Services
Incident Report for Wessex Internet
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2024 - 11:54 BST
Investigating
We are currently investigating an unexpected issue affecting some of our VOIP service customers.
Posted Oct 18, 2024 - 11:15 BST
This incident affects: Contacting us/ Tools/ Portals (Telephone System).