Outage - Hilton
Incident Report for Wessex Internet
Resolved
This incident has been resolved. Apologies for the inconvenience caused.
Posted Jan 08, 2022 - 15:40 GMT
Investigating
We are aware that there is an issue currently affecting customers in Hilton area. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Jan 08, 2022 - 15:29 GMT
This incident affected: Broadband Services (Fixed-wireless Services).