Outage - Berwick St Leonard and surrounding area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 09:21 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2024 - 07:38 BST
Investigating
We are aware that there is an issue currently affecting customers in the Berwick St Leonard Area. An Engineer is on route and we are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Apr 11, 2024 - 06:15 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).