Emergency Maintenance - Hurst Area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 14:16 BST
Investigating
We are currently undertaking crucial emergency maintenance to ensure the health of our network.
Posted Jul 16, 2024 - 13:41 BST
This incident affected: Broadband Services (Fibre to the Premise Services).