The regional suppier has restored mains power. The service is now restored. Our engineer have checked over our equipment on site and are confident we will not have any futher issues now the outage has cleared,
Again We thank you for your continued patience and can only apologise for any inconvenience caused.
Posted May 26, 2025 - 18:38 BST
Update
We are continuing to work on a fix for this issue.
Posted May 26, 2025 - 18:35 BST
Identified
A local power outage by the regional supplier has caused loss of service in the area with an estimated restore time of 19:00. We currently have an engineer on route to site to provide temporary power to restore service as quickly as possible. We will provide a further update as soon as more information becomes available. We apologise for the inconvenience caused and thank you for your patience.
Posted May 26, 2025 - 17:06 BST
This incident affected: Broadband Services (Fixed-wireless Services).