Outage - Galhampton area
Incident Report for Wessex Internet
Resolved
We have implemented a temporary fix and will be sending an engineer out to site to replace the equipment. We apologise for any inconveniences caused
Posted May 03, 2021 - 20:12 BST
Investigating
We are aware that there is an issue currently affecting customers in Galhampton Area. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted May 03, 2021 - 19:25 BST
This incident affected: Broadband Services (Fixed-wireless Services).