Outage - Compton Castle and surrounding areas
Incident Report for Wessex Internet
Resolved
We have replaced the faulty piece of equipment. Thank you for your understanding and patience
Posted Feb 27, 2021 - 00:24 GMT
Investigating
We are aware that there is an issue currently affecting customers in Compton Castle and surrounding areas. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Feb 26, 2021 - 21:18 GMT
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).