Unexpected Partial Outage - Phone Services
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Jun 19, 2024 - 12:24 BST
Investigating
We are currently investigating partial service issues with our phone servers - customers can expect a possible loss of service with our Wessex Telephone servers.
Posted May 30, 2024 - 15:11 BST
This incident affected: Contacting us/ Tools/ Portals (Telephone System).