Unexpected Outage - Thornicombe, Lower Whatcombe & Surrounding Areas
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Dec 12, 2024 - 15:36 GMT
Investigating
We are currently experiencing unexpected issues with our equipment in this area and an engineer is enroute.
Posted Dec 09, 2024 - 14:15 GMT
This incident affected: Broadband Services (Fibre to the Premise Services).