Unexpected outage - Penselwood, Compton Castle, Stourton, South Cadbury, Galhampton, Holton, Yarlington, Wincanton and surrounding areas
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted May 15, 2023 - 08:46 BST
Identified
The issue has been identified and a fix is being implemented.
Posted May 12, 2023 - 12:58 BST
Update
We are continuing to investigate this issue.
Posted May 12, 2023 - 11:11 BST
Investigating
We are aware that there is an issue currently affecting customers in Penselwood, Compton Castle, Stourton, Galhampton, Holton, Yarlington, Wincanton, South Cadbury, and surrounding areas

We are investigating this at the moment, an engineer is en route and further updates will be posted here.
Posted May 12, 2023 - 11:09 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).