Slow Speeds and limited connectivity in Compton Castle Area
Incident Report for Wessex Internet
Resolved
This incident has now been resolved. Apologies for the disruption
Posted Sep 09, 2020 - 12:00 BST
Monitoring
We have created a fix and are monitoring the speeds
Posted Sep 09, 2020 - 09:48 BST
Investigating
We are aware of and currently investigating speed issues in this area
Posted Sep 09, 2020 - 09:25 BST
This incident affected: Broadband Services (Fixed-wireless Services).