Outage - North Cheriton
Incident Report for Wessex Internet
Resolved
This incident has now been resolved - We are sorry for any inconvenience caused
Posted May 07, 2021 - 12:13 BST
Monitoring
A fix has been implemented and we are monitoring the connections
Posted May 06, 2021 - 09:02 BST
Investigating
We are aware that there is an issue currently affecting customers in North Cheriton Area. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted May 06, 2021 - 07:33 BST
This incident affected: Broadband Services (Fixed-wireless Services).