Outage - Cheselbourne
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Oct 04, 2018 - 16:42 BST
Investigating
We have received reports of an outage affecting certain customers in Cheselbourne. We are investigating this and will keep updating this status page.
Posted Oct 04, 2018 - 09:54 BST
This incident affected: Broadband Services (Fixed-wireless Services).