Durweston, Stourpaine, Turnworth - Power outage
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted May 05, 2021 - 16:52 BST
Investigating
We have had an unexpected power outage and affecting customers in the Durweston, Stourpaine, Turnworth and surrounding areas. We are investigating the issue. Apologies for any inconvenience.
Posted May 05, 2021 - 15:48 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).