Outage Farnham Area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 08:43 GMT
Investigating
We are aware that there is an issue currently affecting customers in the Farnham. We are investigating this at the moment, and further updates will be posted here. Apologies for the continuing disruptions to service.
Posted Mar 25, 2020 - 14:38 GMT
This incident affected: Broadband Services (Fixed-wireless Services).