Outage - Bryanston club, Blandford Forum
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Jun 26, 2019 - 09:25 BST
Investigating
We are currently investigating an issue affecting some customers at Blandford Forum area. We have engineers on site working to restore the services as soon as possible. Apologies for any inconvenience.
Posted Jun 25, 2019 - 19:40 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).