Outage Affecting Bryanston/Morden Area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted May 24, 2020 - 11:10 BST
Investigating
Outage Affecting Bryanston/Morden Area Apologies for any inconvenience
Posted May 24, 2020 - 10:53 BST
This incident affected: Broadband Services (Fibre to the Premise Services).