Melbury - Power outage
Incident Report for Wessex Internet
Resolved
This power incident has been resolved. We are sorry for the disruption
Posted Jun 25, 2020 - 22:29 BST
Investigating
We have had an unexpected power outage and affecting customers in the Melbury area. We are investigating the issue. Apologies for any inconvenience.
Posted Jun 25, 2020 - 21:15 BST
This incident affected: Broadband Services (Fixed-wireless Services).