Outage - Durweston and Stourpaine
Incident Report for Wessex Internet
Resolved
We have now resolved this issue.

Sorry for any inconvenience this may have caused.
Posted May 07, 2021 - 22:42 BST
Identified
We are aware that there is an issue currently affecting customers in the Durweston and Stourpaine areas. We are working on this at the moment and further updates will be posted here.

We apologise for any inconvenience this is causing.
Posted May 07, 2021 - 22:30 BST
This incident affected: Broadband Services (Fixed-wireless Services).