Outage - Milton On Stour, Silton
Incident Report for Wessex Internet
Resolved
This incident has been resolved. Apologies for the inconvenience caused.
Posted Dec 08, 2022 - 16:31 GMT
Identified
Fibre break has been identified. We have engineers on site working to restore the services as soon as possible.
Posted Dec 08, 2022 - 14:54 GMT
Investigating
We are aware that there is an issue currently affecting customers in Milton On Stour, Silton and surrounding areas. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Dec 08, 2022 - 14:34 GMT
This incident affected: Broadband Services (Fibre to the Premise Services).