Outage in Cheselbourne / Bullen area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Mar 16, 2018 - 04:38 GMT
Investigating
We are aware of an outage in the Cheselbourne / Bullen area.

Engineers are on the way and we will post updates here as we have them.

We apologise for any inconvenience that this is causing.

The Wessex Internet Engineering Team
Posted Mar 08, 2018 - 09:51 GMT