Melbury Beacon Area - Degraded Performance
Incident Report for Wessex Internet
Resolved
This incident has been resolved. Apologies for the inconvenience caused.
Posted Jul 21, 2021 - 15:44 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2021 - 11:21 BST
Investigating
We are aware that there is an issue currently affecting customers in Melbury Beacon, Sturminster Newton, Shaftesbury and surrounding areas. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Jul 21, 2021 - 10:30 BST
This incident affected: Broadband Services (Fixed-wireless Services).