Outage Durweston, Turnworth and Stourpaine Area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Sep 09, 2019 - 15:03 BST
Identified
Outage Durweston, Turnworth and Stourpaine Area, apologies for any inconvenience. We are working quickly to resolve the issue.
Posted Sep 09, 2019 - 11:27 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).