Wessex Internet email
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Jun 11, 2020 - 12:45 BST
Identified
We have been experiencing an issue with receiving emails to our Customer Service and Sales Teams. If you have sent us an email recently and have not had a response, please resend the email to us as we are in the process of resolving the issue. One of our team will members will then be in touch. Apologies for any inconvenience.
Posted May 20, 2020 - 15:25 BST