Hilton Intermittent Network Issues
Incident Report for Wessex Internet
Resolved
This incident has been resolved. We are aware of the issues in this area and within a month will be installing new equipment to improve service. Thank you for your patience and understanding
Posted Jun 25, 2020 - 11:55 BST
Investigating
We are aware that there is an issue affecting certain customers on our network. We are investigating this as a matter of urgency and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Jun 24, 2020 - 09:58 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).