Outage - Piddlehinton
Incident Report for Wessex Internet
Resolved
The incident is now resolved. Sorry for any inconvenience.
Posted Nov 29, 2018 - 09:21 GMT
Investigating
We are aware that there is an issue affecting some customers in Piddlehinton. An engineer is en route. Further updates will be posted here.

We apologise for any inconvenience.
Posted Nov 28, 2018 - 16:18 GMT
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).