Outage Hinton St Mary
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 18:03 GMT
Investigating
Outage affecting Hinton St Mary area, apologies for any inconvenience.
Posted Jan 13, 2020 - 11:32 GMT
This incident affected: Broadband Services (Fixed-wireless Services).