Outage Cranbourne Area
Incident Report for Wessex Internet
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 22:05 GMT
Investigating
Outage affecting Cranbourne area - apologies for any inconvenience
Posted Jan 16, 2020 - 11:04 GMT
This incident affected: Broadband Services (Fibre to the Premise Services).