Outage - Cheselbourne
Incident Report for Wessex Internet
Resolved
The faulty equipment has been replaced. All services back up and running. Apologies for any inconvenience caused.
Posted May 07, 2022 - 11:49 BST
Investigating
We are aware that there is an issue currently affecting customers in Cheselbourne, Dewlish areas. We have engineers on route, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted May 07, 2022 - 09:54 BST
This incident affected: Broadband Services (Fixed-wireless Services).