Outage - Turnworth
Incident Report for Wessex Internet
Resolved
This incident has been resolved. Apologies for the inconvenience caused.
Posted Sep 30, 2022 - 13:11 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2022 - 11:59 BST
Update
We have engineers on route to the site.
Posted Sep 30, 2022 - 11:27 BST
Investigating
We are aware that there is an issue currently affecting customers in Turnworth and surrounding areas. We are investigating this at the moment, and further updates will be posted here.

We apologise for any inconvenience caused.
Posted Sep 30, 2022 - 10:53 BST
This incident affected: Broadband Services (Fixed-wireless Services, Fibre to the Premise Services).