Wessex Internet - Phone System
Incident Report for Wessex Internet
Resolved
This incident has now been resolved. Sorry for any inconvenience caused.
Posted Feb 06, 2019 - 17:00 GMT
Investigating
We are currently experiencing issues with our phone system. We are currently investigating this issue.
Posted Feb 06, 2019 - 10:57 GMT
This incident affected: Contacting us/ Tools/ Portals (Telephone System).